Materiel Celeste

Forum francophone pour les collectionneurs et créateurs de poupées
 
AccueilAccueil  S'enregistrerS'enregistrer  ConnexionConnexion  

Partagez
 

 Problème de connexion: noms d'utilisateurs/trices

Aller en bas 
AuteurMessage
Anne-Laure
Admin
Anne-Laure

Nombre de messages : 28663
Localisation : Angoulême, France
Date d'inscription : 13/11/2004

Problème de connexion: noms d'utilisateurs/trices  Empty
MessageSujet: Problème de connexion: noms d'utilisateurs/trices    Problème de connexion: noms d'utilisateurs/trices  EmptyVen 15 Mar 2019 - 18:21

J'ai déjà dû régler la situation d'au moins trois membres qui ne pouvaient plus se connecter au forum alors que leurs comptes étaient parfaitement actifs et leurs mots de passe inchangés. Le forum leur répondait que leur mdp ou leur nom était invalide, et quand iels tentaient de changer leurs mots de passe via le formulaire automatique, ça leur répondait que leur email n'était pas le bon.

Leur point commun: leurs noms d'utilisateurs contenaient tous un caractère spécial comme & ou ¨ (un tréma).
Cela fait des lustres qu'il est indiqué ici en bas de page qu'il faut éviter les caractères spéciaux dans les ID, mais peu de gens en tiennent compte. Là le bug que ça provoque est encore plus ennuyeux.
Les caractères spéciaux sont les tirets, apostrophes, guillemets, esperluettes, accents... bref tout ce qui n'est pas une lettre ou un chiffre simple (le undercore "_" n'est pas affecté non plus).

Je vous conseille fortement si vous avez ce genre de caractère dans votre nom, d'aller dans votre profil et de le changer.

Heureusement: si vous rencontrez ce souci, votre compte n'est pas perdu, c'est facile à corriger. Contactez une admin, et nous vous fournirons un nouveau mot de passe par mail. Vous devez avoir une adresse email valide.

D'où ça vient?

Le 12 février il y a eu un bug qui laissait les messages vides. Forumactif a réglé l'affaire mais a prévenu:

A propos du bug de messages vides :
forumactif a écrit:
Ce problème touche les vieux forums NON UTF-8 dont les admins ont ignoré notre recommandation d'encoder intégralement leurs forums en UTF-8...

Nous avons lancé une restauration du contenu perdu. Les éléments pouvant être récupérés l’ont étaient. Tous les messages restant vide actuellement ne peuvent pas être récupéré. Il s’agit pour la plupart de messages contenant de l'HTML ayant étaient posté aujourd’hui entre 12h20 et 14h00 UTC+1

Sachez qu’à terme, nous ne pourrons pas maintenir un développement à deux vitesses UTF-8/NON UTF-8 dès lors que l'UTF-8 est l'encodage conçu pour coder l'ensemble des caractères d'une page internet dans une norme internationale totalement compatible avec le standard Unicode et que vous avez tous la possibilité de l'appliquer sur votre forum pour éviter ce genre de problèmes.

Je n'avais jamais reçu cette notif et donc jamais demandé à changer l'encodage du forum. Là j'en ai fait la demande, mais du coup, depuis, on a ce souci de caractères spéciaux qui font bugguer certains comptes.

_________________
Problème de connexion: noms d'utilisateurs/trices  Alg_sigbjd
avatar © Tatsuya Ishida / Sinfest
Revenir en haut Aller en bas
http://algesiras.free.fr
 
Problème de connexion: noms d'utilisateurs/trices
Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» [AIDE] Problème de connexion wifi
» Problème de connexion [Résolu]
» Probleme qui est chia** /!\
» [AIDE] problème de connexion Wifi Orange
» [RESOLU] Problème Wifi activée mais impossible de lire les Mails

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Materiel Celeste :: Le Forum :: Remarques & suggestions-
Sauter vers: